Google Code Jam 2012: Qualification Problem 2


Improve your writing skills in 5 minutes a day with the Daily Writing Tips email newsletter.

This problem was worth 20 points, and you needed to think about it a bit, but finding the answer wasn’t that difficult.

The Problem

You’re watching a show where Googlers (employees of Google) dance, and then each dancer is given a triplet of scores by three judges. Each triplet of scores consists of three integer scores from 0 to 10 inclusive. The judges have very similar standards, so it’s surprising if a triplet of scores contains two scores that are 2 apart. No triplet of scores contains scores that are more than 2 apart.

For example: (8, 8, 8) and (7, 8, 7) are not surprising. (6, 7, 8) and (6, 8, 8) are surprising. (7, 6, 9) will never happen.

The total points for a Googler is the sum of the three scores in that Googler’s triplet of scores. The best result for a Googler is the maximum of the three scores in that Googler’s triplet of scores. Given the total points for each Googler, as well as the number of surprising triplets of scores, what is the maximum number of Googlers that could have had a best result of at least p?

For example, suppose there were 6 Googlers, and they had the following total points: 29, 20, 8, 18, 18, 21. You remember that there were 2 surprising triplets of scores, and you want to know how many Googlers could have gotten a best result of 8 or better.

With those total points, and knowing that two of the triplets were surprising, the triplets of scores could have been:

10 9 10
6 6 8 (*)
2 3 3
6 6 6
6 6 6
6 7 8 (*)

The cases marked with a (*) are the surprising cases. This gives us 3 Googlers who got at least one score of 8 or better. There’s no series of triplets of scores that would give us a higher number than 3, so the answer is 3.

Input

The first line of the input gives the number of test cases, T. T test cases follow. Each test case consists of a single line containing integers separated by single spaces. The first integer will be N, the number of Googlers, and the second integer will be S, the number of surprising triplets of scores. The third integer will be p, as described above. Next will be N integers ti: the total points of the Googlers.

Output

For each test case, output one line containing “Case #x: y”, where x is the case number (starting from 1) and y is the maximum number of Googlers who could have had a best result of greater than or equal to p.

Limits

1 ≤ T ≤ 100.
0 ≤ S ≤ N.
0 ≤ p ≤ 10.
0 ≤ ti ≤ 30.
At least S of the ti values will be between 2 and 28, inclusive.
Small dataset

1 ≤ N ≤ 3.
Large dataset

1 ≤ N ≤ 100.
Sample Input
4
3 1 5 15 13 11
3 0 8 23 22 21
2 1 1 8 0
6 2 8 29 20 8 18 18 21

Sample Output
Case #1: 3
Case #2: 2
Case #3: 1
Case #4: 3

My Solution

I simply calculated the max score for all participants with and without the surprise factor, and then traversed through those values figuring out the max number of participants who could reach the desired score.

#include <stdio.h>

/*finds max score of each googler without surprises allowed*/
void findMaxScoreWithout(int googlers, int best, int scores[], int maxWithout[]){
  int i;
  int baseScore, remainder;

  for (i=0;i<googlers;i++){
    baseScore = scores[i] / 3;
    remainder = scores[i] % 3;
    if (remainder==0)
      maxWithout[i]=baseScore;
    else
      maxWithout[i]=baseScore+1;
  }

  return;
}

/*finds max score of each googler with surprises allowed*/
void findMaxScoreWith(int googlers, int best, int scores[], int maxWith[]){
  int i;
  int baseScore, remainder;

  for (i=0;i<googlers;i++){
    if (scores[i]==0){
      maxWith[i]=0;
      continue;
    }
    baseScore = scores[i] / 3;
    remainder = scores[i] % 3;
    if (remainder<2)
      maxWith[i]=baseScore+1;
    else
      maxWith[i]=baseScore+2;
  }

  return;
}

/*finds max number of googlers who can reach top score*/
int findTopGooglers(int googlers, int surprises, int best, int maxWithout[], int maxWith[]){
  int total = 0;
  int i;
  for (i=0;i<googlers;i++){
    if (maxWithout[i]>=best){
      total++;
      maxWithout[i]=-1;
    }
  }
  for (i=0;i<googlers;i++){
    if (surprises>0){
      if (maxWithout[i]!=-1){
        if (maxWith[i]>=best){
          total++;
          surprises--;
        }
      }
    }
  }

  return total;
}

int main(){
  int i,j,cases,result;
  int googlers,surprises,best;
  int scores[100]; /*total score of each googler*/
  int maxWithout[100]; /*max score of each googler without surprise*/
  int maxWith[100]; /*max score of each googler with surprise*/

  scanf("%d",&cases);

  for (i=0;i<cases;i++){
    scanf("%d %d %d",&googlers,&surprises,&best);
    for (j=0;j<googlers;j++)
      scanf("%d",&scores[j]);
    findMaxScoreWithout(googlers,best,scores,maxWithout);
    findMaxScoreWith(googlers,best,scores,maxWith);
    result = findTopGooglers(googlers, surprises, best, maxWithout, maxWith);
    printf("Case #%d: ", i+1);
    printf("%d",result);
    if (i<cases-1)
      printf("n");
  }

return 0;
}

Leave a Reply

Your email address will not be published. Required fields are marked *