Google Code Jam 2013 – Qualification Round Problem 1


Improve your writing skills in 5 minutes a day with the Daily Writing Tips email newsletter.

Tic-Tac-Toe-Tomek is a game played on a 4 x 4 square board. The board starts empty, except that a single ‘T’ symbol may appear in one of the 16 squares. There are two players: X and O. They take turns to make moves, with X starting. In each move a player puts her symbol in one of the empty squares. Player X’s symbol is ‘X’, and player O’s symbol is ‘O’.

After a player’s move, if there is a row, column or a diagonal containing 4 of that player’s symbols, or containing 3 of her symbols and the ‘T’ symbol, she wins and the game ends. Otherwise the game continues with the other player’s move. If all of the fields are filled with symbols and nobody won, the game ends in a draw. See the sample input for examples of various winning positions.

Given a 4 x 4 board description containing ‘X’, ‘O’, ‘T’ and ‘.’ characters (where ‘.’ represents an empty square), describing the current state of a game, determine the status of the Tic-Tac-Toe-Tomek game going on. The statuses to choose from are:

“X won” (the game is over, and X won)
“O won” (the game is over, and O won)
“Draw” (the game is over, and it ended in a draw)
“Game has not completed” (the game is not over yet)
If there are empty cells, and the game is not over, you should output “Game has not completed”, even if the outcome of the game is inevitable.

Input

The first line of the input gives the number of test cases, T. T test cases follow. Each test case consists of 4 lines with 4 characters each, with each character being ‘X’, ‘O’, ‘.’ or ‘T’ (quotes for clarity only). Each test case is followed by an empty line.

Output

For each test case, output one line containing “Case #x: y”, where x is the case number (starting from 1) and y is one of the statuses given above. Make sure to get the statuses exactly right. When you run your code on the sample input, it should create the sample output exactly, including the “Case #1: “, the capital letter “O” rather than the number “0”, and so on.

Limits

The game board provided will represent a valid state that was reached through play of the game Tic-Tac-Toe-Tomek as described above.

Small dataset

1 ≤ T ≤ 10.

Large dataset

1 ≤ T ≤ 1000.

Sample Input

6
XXXT
….
OO..
….

XOXT
XXOO
OXOX
XXOO

XOX.
OX..
….
….

OOXX
OXXX
OX.T
O..O

XXXO
..O.
.O..
T…

OXXX
XO..
..O.
…O

Sample Output
Case #1: X won
Case #2: Draw
Case #3: Game has not completed
Case #4: O won
Case #5: O won
Case #6: O won

My Solution

Brute force solved the problem correctly and in time.

#include <stdio.h>

char* processBoard(char board[][4]){
  int i,j;
  int countX;
  int countO;
  int empty = 0;

  /*check rows*/
  for(i=0;i<4;i++){
    countX = 0;
    countO = 0;
    for(j=0;j<4;j++){
      if(board[i][j]=='.')
        empty = 1;
      else if(board[i][j]=='T'){
        countX++;
        countO++;
      }
      else if(board[i][j]=='X')
        countX++;
      else if(board[i][j]=='O')
        countO++;
    }
    if(countX==4)
      return "X won";
    else if(countO==4)
      return "O won";
  }

  /*check columns*/
  for(i=0;i<4;i++){
    countX = 0;
    countO = 0;
    for(j=0;j<4;j++){
      if(board[j][i]=='T'){
        countX++;
        countO++;
      }
      else if(board[j][i]=='X')
        countX++;
      else if(board[j][i]=='O')
        countO++;
    }
    if(countX==4)
      return "X won";
    else if(countO==4)
      return "O won";
  }

  /*check diagonals*/
  countX = 0;
  countO = 0;
  for(i=0;i<4;i++){    
    if(board[i][i]=='T'){
      countX++;
      countO++;
    }
    else if(board[i][i]=='X')
      countX++;
    else if(board[i][i]=='O')
      countO++;  
  }
  if(countX==4)
      return "X won";
    else if(countO==4)
      return "O won";

  countX = 0;
  countO = 0;
  for(i=0;i<4;i++){    
    if(board[i][3-i]=='T'){
      countX++;
      countO++;
    }
    else if(board[i][3-i]=='X')
      countX++;
    else if(board[i][3-i]=='O')
      countO++;    
  }
  if(countX==4)
      return "X won";
    else if(countO==4)
      return "O won";

  /*no winners foundd*/
  if(empty)
    return "Game has not completed";
  else
    return "Draw";
}

int main(){
  int i,j;
  int t,k;
  char board[4][4];
  char c;
  char *result;

  scanf("%d",&t);
  c = getchar();
  
  for(k=0;k<t;k++){
    for(i=0;i<4;i++){
      for(j=0;j<4;j++){
        c = getchar();
        board[i][j] = c;
      }
      c = getchar();
    }
    
    result = processBoard(board);

    if(k>0)
      printf("n");
    printf("Case #%d: %s",k+1,result);

    c = getchar();
  }

  return 0;
}

Leave a Reply

Your email address will not be published. Required fields are marked *